authorisation of consent

I think the response I get upon creating a consent is insufficient. "_links": { "self": {}, "status": {}, "scaOauth": { "href": "https://www.testbank.com/oauth/.well-known/oauthauthorization-server" }, "scaStatus": {} } the authorisation of the consent is not working. no scaStatus is being returned. Can you kindly send me your preferred workflow in sandbox api testing? Thanks

Comments

  •  
    What's the authorization workflow for a consent to get a scaSatus and consentstatus so the readaccountlist and read transactions list APIs will be accessible we now get a 500 error probably beacuse the consent is not given yet?
    Posted by Hidden Thu, 18 Jul 2019 12:24:24 GMT
  •  
    Dear Maarten, The flow is as follows: Step 1: Create consent. This will return a consentId Step2: start Oauth2 workflow to get a code to retrieve an access token Step3: retrieve access token based on the returned code The access token is required to retrieve account information. For the consent status request only the certificate based authentication is required, not the access token. Kind regards, Erik
    Posted by Hidden Fri, 19 Jul 2019 09:53:18 GMT
  •  
    Dear Maarten, At the moment, the best way to test the API is making use of a tool like Postman. For [GET] Accounts request, only the 'Request Url' and the 'Ocp-Apim-Subscription-Key' in the header are required. In the response body you can use the resourceIds with the [GET] Account request, where the 'Ocp-Apim-Subscription-Key' in the header is also are required. Kind regards, Andy
    Posted by Hidden Fri, 19 Jul 2019 11:08:27 GMT
  •  
    Dear Maarten, As of today we are providing an interactive sandbox where the authorisation can be tested
    Posted by Hidden Tue, 30 Jul 2019 17:26:02 GMT
  •  
    Thank you for the update. Something seems to be missing in our requests could you give us some guidance? We've tried through Postmans and C# code as well. This is the error code we receive: { "code": "CERTIFICATE_MISSING", "type": "https://berlingroup.com/error-codes/CERTIFICATE_MISSING", "title": "Missing in: QWAC", "statusCode": 401 } We use a general QSEAL certificate for which we calculate a valid TPP-Signature-Certificate. We've set the certificate inclusing the sandbox hostname in Postman as well. Any help would be appreciated.
    Posted by Hidden Wed, 31 Jul 2019 10:31:51 GMT
  •  
    You will also need to setup mutual SSL TLS connection using the (test) QWAC certificate
    Posted by Hidden Wed, 31 Jul 2019 10:54:05 GMT


You're not signed in. Please sign-in to report an issue or post a comment.